PDA

View Full Version : Alert change after softwareupdate (6210)



max232
02-07-2002, 04:44 PM
My first try to flash a 6210 was changing the sms-alert and it worked fine. But now I've changed the software to 5.56 (seems to be OK - >backup entries >factory defaults >backup phone >flash sw >factory defaults >faid >imei [was correct] >restore entries =>:) )
Now I've retried to change the sms-alert ( >backup >modify >checksums >flash) but afterwards the phone has no signal and I can't update the FAID (has no effect) and if I change the security-code the phone will hang up. Flashing back the backup works but is not what I want. So want's wrong after the Update?

Please give a try to help me...

Liam
03-07-2002, 08:42 AM
MCU checksums arent correct?

To have phone working after flashing these must be correct...

MCU checksum
PPM checksum
FAID

MCU is normally ok each time as most of use dont mess with that.... but you can correct it with Rolis DCT3 Flasher 4.77
PPM is checked with PPM Manager
FAID is calculated with EEPROM Tools or Knok

max232
03-07-2002, 10:13 PM
I didn't tough the MCU by changing the sms-alert because it's in the PPM, so the FAID-effect shoudn't appear. But it does, athough I only changed 4 Bytes in the PPM (2 for changing the beep and the others were changed by NFree1.2 or PPM Manager - they both do the same on my dump - I've compared them and other checksums are correct according to NFree...). And when I changed the alert the time before I soft-updated my phone, this procedure has worked fine (without FAID or IMEI - problems). Of course, I took a new full-backup from the phone for the changing after I've restored my entries because of the softupdate. So why MCU 5.56 does'nt accept the 4-Byte changing in his PPM?

NokDoc
03-07-2002, 10:54 PM
Full safety procedure after modifications:

Most important, use mcu&ppm only.

To have phone working after flashing these must be correct...

MCU checksums
PPM checksums
Flash checksum

use nfree12 for recalc mcu
use ppm manager for ppm & flash chk
flash and update faid.

To check if certain version can be modified:
do recalc on a copy of Ur working backup with ppm manager and compare the last 4 bytes from the ppm.
If they differ from the original U better forget that version.

But to ease Ur pain of doing that, the 6210-556 can be done.

NokDoc

max232
04-07-2002, 06:27 AM
I wonder what PPM Manager is doing. A saved dump form PPM Manager is total different to the original and roli check says "EEPROM string not found". A flash will produce a "contact service" - message and this happens when I take my very first clean backup, too. All dumps PPM Manager saves are said to be bad by programs like roli or NFree12. During my first try I used NFree to correct PPM checksum => no problem! (4 different Bytes)
But this doesn't work with http://www.cubwolf.btinternet.co.uk/upgrades/6210v556.zip. Perhaps there is something wrong with it?!?

Liam
04-07-2002, 08:34 AM
Perhaps that file is corrupt yes.

Locate another source for the flash file, I can email you a working flash file if you give me an email address that accepts large flash files

NokDoc
04-07-2002, 11:54 AM
Hi,

Working files should stay the same if U only do recalc without changing the data.

What ppm manager are U using?
The 091 version from Mr. From_Vanov?

NokDoc

max232
04-07-2002, 05:22 PM
Yes, they should stay, but PPM Manager 091 (Mr. From_Vanov) replaces a lot of bytes with 0xFF where something importent like eeprom-strings have to be located.
Now, I run my old working, modified 5.17, but I've trouble with the calendar - sometimes it doesn't remind me at the time I've typed, but at 24 o`clock all alert from that day are belling :( - Do U know a good bug-list? Which bug in which version is known or fixed and so on...
U can mail me a 556 to d_a_u@web.de - perhaps a zip (50%) - thanks!
What does fchk make? It runs since 30 minutes and has only printed 2 MCU chks (and the second differs from the calced on a well working file), but it doesn't finished yet.

NokDoc
05-07-2002, 02:39 PM
Hi Mr. Max32,

I checked some things:

PPM manager doesn't change things after recalc and saving.
So that can't be the problem.

This file U sent in should work correct.

But I cannot test, no 6210.

Fchk;
I sended wrong version, sorry about that.
It suppose to help in finding incorrect checks.

NokDoc

max232
07-07-2002, 06:14 AM
Thanks for "fchk"! That was the key!
After correcting checksums with NFree12, I checked the dump with fchk and got:
== nFree Calc 0.1b == <D0C1>

Analysing file...

#Mcu Chk 1 : C686 (C686 calced)
#Mcu Chk 2 : C686 (C686 calced)
#Ppm (01) : 885D9C09 (885D9C09 calced)
#Ppm (02) : B3D023AA (B3D023AA calced)
#Ppm (03) : 8AA22277 (8AA22277 calced)
#Ppm (04) : 71089D4B (71089D4B calced)
#Ppm (05) : E18F4F09 (E18F4F09 calced)
#Ppm (06) : F6797ACA (F6797ACA calced)
#Ppm (07) : E49BECD9 (E49BECD9 calced)
#Ppm (08) : 54E384D5 (54E384D5 calced)
#Flash Chk : B5C3B02C (E63C1FE5 calced) <== HERE!

The last checksum wasn't corrected by any program! And so the FAID-Update failed every time.
I changed it manually with a Hex-edit from readed to calced and used KNOK-Quick FAID-Setup after flashing back and restarted the phone. Now I'm happy, because it was the second time, this happend to me. I flash a 6250 software (everything OK) and want to modify it, but after every flash the FAID couldn't be update...

Now everything is fine and thanks for spending time in Newbies problems!