View Full Version : 5190 Data Cable Unlock Help

07-04-2004, 08:16 AM
I need help unlocking my two Nokia 5190 phones. They were locked after several bad attempts of trying to remotely unlock them. Therefore, I purchased the data cable which is supposed to support Mbus/Fbus and a link to the picture is here: http://www.asianproducts.com/images/pbimage/1/A10143343512922b.jpg

I would like to know what do I do from this point? The cable is OEM and did not come with any software. I unfortunately do not have a serial port in my laptop so will have to use another PC which does. However, the operating system is windows xp do I need a driver for this serial cable? what about compatibility problems with xp? What software do I need to unlock it? What is the procedure I must follow? Plug the serial port before turning the pc? or after? turn the phone before I plug it in? So many questions!

Any help would be greatly appreciated.

Many thanks :)


07-04-2004, 01:53 PM
search for rolis tools 1.8 and everything is straight forward from there,

07-04-2004, 04:17 PM
search for rolis tools 1.8 and everything is straight forward from there,

Ok well I got it on floppy and am going to try it on another computer since I found it last night and tried another computer here at home that is kinda old, but has xp on it and when I plugged in cable to the back of the pc, plugged it to the phone, I got an error code 955.

So will try it at my mother in law's now. I am hoping it was the pc and not the cable or anything else.

That's why I asked if I needed a driver or anything for this cable???? and if rolis works well with xp????

07-04-2004, 08:28 PM
Moving on...

Ok well, I tried it at another PC that has XP, so I installed NokTool and then hooked the data cable to the serial port, and then to my phone. I starting using NokTool by first clicking on interface setup. It gave the following message: Found Phone on COM1, Active power line are:RTS

So then I clicked on Read Phone Info and it displayed all the information. Change IMEI was checked and then I proceeded to click on: Clear SP Locks and then got an Error Message saying: SP initialisation failed. So where do I go from here?!

Also, am I supposed to have the phone with a SIM card in it or not???