Results 1 to 4 of 4

Thread: Sony W850I problem

  1. #1

    Sony W850I problem

    Ive got a Sony w850I
    When you power it on you get a white screen flash then it turns off but then contiues to try to turn on thne it repeats the above over and over ?
    Could this be a firmware issue or a screen problem.
    Theres no sign of the phone being dropped or imerseed in water .
    Any help would be cool
    psxprince@yahoo.com

    Sorry for short description my nety access is failing so only on ofr a few minutes

    Antony

  2. #2
    the phone needs a reflash

  3. #3

    Smile

    u need epron update,,,,,this free,,,,,,,go sony ericsson website an down the soft to update ur mob.....this free ......
    http://www.sonyericsson.com/spg.jsp?...=ps1&pid=10447
    just use the update service,,,use ur cable come with mob.....
    software will do everything for you ...
    1st thimg software do is update the epron for you...then mob work properly...up to you if you want carry on then updating everything.....
    i know all this cos same happen to me......an i got setool.....but this way its all free.....
    good luck

  4. #4
    the phone needs a reflash

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. sony j70 - screen problem
    By aleksi1212 in forum Old Sony phones
    Replies: 0
    Last Post: 12-02-2004, 07:58 AM
  2. 6510 very coman problem
    By sagarka in forum 65XX / 82xx / 83xx / 88xx / 89XX [Closed]
    Replies: 1
    Last Post: 24-01-2003, 08:17 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •